[mpm-itk] User/group php and resolving

Edwin Ringersma edwin at introweb.nl
Wed Jan 30 19:55:12 CET 2008



On Wed, 30 Jan 2008 18:14:35 +0100, "Steinar H. Gunderson"
<sgunderson at bigfoot.com> wrote:
> On Wed, Jan 30, 2008 at 05:02:40PM +0100, Edwin Ringersma wrote:
>> I'm facing 2 problems.
>> 1. user/group is showing as #-1/-1 in phpinfo.
>>    apache is running as the defined user, so that is working fine.
>>    Is this a quirk that should be ignored ?
> 
> AFAIK this is a PHP bug.
Ok, I'll just ignore it then.
> 
>> 2. hostname resolving for things like fopen, fsockopen, include is not
>> working.
>>   But using the ip-adres is working just fine.
> 
> That's strange; I've never seen anyone report that before. Does resolving
> outside of PHP work?
Yes it does. I've tried 3 different ip-addresses as a nameserver among
which localhost (ran named) Strangely enough, if I run a php-script that is
resolving a hostname
from the commandline, it does work fine. So it looks as if it's a
combination of php and apache.

-Edwin
> 
> /* Steinar */
> --
> http://www.sesse.net/




More information about the mpm-itk mailing list