[mpm-itk] Making libcap support configurable

Michael Orlitzky michael at orlitzky.com
Thu May 22 19:59:34 CEST 2014


Hello, I'm finally getting around to packaging the 2.4.x series for
Gentoo. I noticed that libcap support is detected at build time -- this
is what we call an automagic dependency[1].

The simplest reason why it can cause problems for us is that the
build-host may not be the run-host. So the features detected at build
time can be incorrect. (In any case, we prefer to give the user the
option to disable such features even if it means shooting himself in the
foot.)

So, I have a feature request: can libcap support be enabled/disabled
with e.g. --enable/disable-libcap in the configure script? This is not a
major issue since we can require libcap unconditionally (thereby
requiring both the build- and run-host to have it installed), but is a
"nice to have."

Thank you.


[1]
https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Automagic_dependencies



More information about the mpm-itk mailing list